Scheduled Maintenance

Maintenance
October 26, 12:00am

Scheduled Maintenance

Status: closed
Start: October 25, 8:00pm
End: October 26, 12:00am
Duration: 4 hours
Affected Components:
Grant & Aid Payment Plans
Update

October 25, 8:00pm

October 25, 8:00pm

We're undergoing maintenance for Enterprise Test and Production from 20:00 to 23:59. You may experience intermittent disruptions during this period. Thank you for your patience!

Resolved

October 26, 12:00am

October 26, 12:00am

Maintenance is now complete.