Issues with Incoming Phone Calls

Incident
August 15, 1:26pm

Issues with Incoming Phone Calls

Status: closed
Start: August 15, 12:05pm
End: August 15, 1:26pm
Duration: 1 hour 20 minutes
Affected Components:
Wait Times -- Phone Systems
Update

August 15, 12:05pm

August 15, 12:05pm

Our phone systems are experiencing issues with incoming calls. We are investigating and working toward a resolution. In the meantime, you are welcome to contact your Account Manager.

Thank you for your patience.

Resolved

August 15, 1:26pm

August 15, 1:26pm

This issue has been resolved. Thank you for your patience.