SIS Student Billing and Cash Register

Unavailable
May 13, 11:09am

SIS Student Billing and Cash Register

Status: closed
Start: May 13, 7:44am
End: May 13, 11:09am
Duration: 3 hours 25 minutes
Affected Components:
FACTS SIS (RenWeb 1)
Update

May 13, 7:44am

May 13, 7:44am

FACTS SIS is experiencing technical issues.   Technical resources are engaged.  Thank you for your patience.

Resolved

May 13, 11:09am

May 13, 11:09am

n/a