Call Center Issues

Incident
March 12, 8:59am

Call Center Issues

Status: closed
Start: March 12, 8:49am
End: March 12, 8:59am
Duration: 10 minutes
Affected Components:
Wait Times -- Phone Systems
Update

March 12, 8:49am

March 12, 8:49am

We are currently experiencing call center issues.  Technical resources are engaged.  Thank you for your patience.

Resolved

March 12, 8:59am

March 12, 8:59am

na

Root Cause

March 12, 8:59am

March 12, 8:59am

na