Donor Connect application issue

Performance
January 11, 2:18pm

Donor Connect application issue

Status: closed
Start: January 11, 11:18am
End: January 11, 2:18pm
Duration: 3 hours
Affected Components:
Donor Connect (Legacy System)
Update

January 11, 11:18am

January 11, 11:18am

We are experiencing issues affecting the application

Resolved

January 11, 2:18pm

January 11, 2:18pm

This has been resolved. The Donor Connect application is working again.