FACTS SIS

Unavailable
December 17, 8:19am

FACTS SIS

Status: closed
Start: December 17, 7:49am
End: December 17, 8:19am
Duration: 30 minutes
Affected Components:
FACTS Application FACTS Enrollment
Update

December 17, 7:49am

December 17, 7:49am

FACTS SIS is experiencing issues with the Admissions page.   Technical resources are engaged.   Thank you for your patience.

Resolved

December 17, 8:19am

December 17, 8:19am

n/a

Root Cause

December 17, 8:19am

December 17, 8:19am

n/a