Phone system is experiencing issues
Incident Report for FACTS
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 24, 2019 - 08:35 CDT
Investigating
We are currently investigating this issue.
Posted 21 days ago. Sep 24, 2019 - 07:54 CDT