School Site
Incident Report for FACTS
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 02, 2019 - 11:39 CDT
Update
Users may experience intermittent outages.
Posted 2 months ago. Aug 02, 2019 - 10:47 CDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Aug 02, 2019 - 10:27 CDT
This incident affected: School Site.