Payment Plans
Incident Report for FACTS
Resolved
This incident has been resolved.
Posted 18 days ago. Sep 27, 2019 - 13:57 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 18 days ago. Sep 27, 2019 - 11:58 CDT
Investigating
When users make a payment, they receive an error which appears to them that the transaction failed. However, the transactions are not failing and are successful.
• Resources are engaged and researching the issue
Posted 18 days ago. Sep 27, 2019 - 11:27 CDT
This incident affected: FACTS SIS (RenWeb 1).