Cash Register
Incident Report for FACTS
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 10, 2019 - 17:07 CDT
Update
We are continuing to investigate this issue.
Posted 6 months ago. Apr 10, 2019 - 09:56 CDT
Investigating
Errors when charging a Staff member in the new Cash Register. Customer Support has been alerted to this issue.
Posted 6 months ago. Apr 10, 2019 - 09:56 CDT
This incident affected: FACTS SIS (RenWeb 1).