FACTS SIS and OAOE unable to login
Incident Report for FACTS
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 09, 2019 - 10:55 CDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Sep 09, 2019 - 10:44 CDT
This incident affected: FACTS SIS (RenWeb 1), FACTS Application (Online Application), FACTS Enrollment (Online Enrollment), and School Site.