Staff HD App Issues
Incident Report for FACTS
Resolved
Issue has been resolved, download the latest update from the app store.
Posted 9 months ago. Feb 01, 2019 - 18:20 CST
Identified
Technical resources have identified the issue and working on a fix.
Posted 9 months ago. Jan 24, 2019 - 15:02 CST
Investigating
We are currently experiencing issues with Attendance & Grade Book in Staff HD App, please use RenWeb 1 on your iPad to access these items until the issue is resolved.
Posted 9 months ago. Jan 24, 2019 - 14:45 CST